> Remote Control > Using Direct Connect with Devices with Older Agents

Using Direct Connect with Devices with Older Agents

If you use Direct Connect to remote control to devices with pre-version 10.2 agents, you must choose a plugin or downloadable executable to run the remote control session.

The following browsers support the NTR Thick Client used to connect to devices that have not been upgraded to version 11.0.

Browser Version Plugin Downloadable exe.
Internet Explorer 11 and newer
FireFox* 40.0.3 and newer
Chrome 45 and newer X
pre-45
MS Edge   X